Author Topic: Access old firmwares  (Read 312 times)

bdevlin

  • Newbie
  • *
  • Posts: 38
    • View Profile
Access old firmwares
« on: April 02, 2017, 11:24:41 pm »
I updated my gateway to the latest software and firmware 06-367 and 0.7-421.

The gateway no longer accepts messages from my modules scripts at all, so my entire test scenario is now broken. I am using the latest mc-Studio 0.7-906, and the gateway can connect, but will not detect devices for programming at all. I have one device sitting directly on top of the gateway. The beacons do show for all modules in range. Very frustrating. Any tips or an archive of old soft/firmwares please.

I have four active modules working reasonably well before this update.

Thanks,
Brad

Social Buttons


mc-T2

  • Administrator
  • Full Member
  • *****
  • Posts: 239
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Re: Access old firmwares
« Reply #1 on: April 03, 2017, 09:56:50 am »
Hey bdevlin,

Can you confirm what firmware you have for the modules? When firmware is updated, it is best to ensure that all devices and software are up to date.
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB

bdevlin

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Access old firmwares
« Reply #2 on: April 03, 2017, 11:22:21 am »
I have the following modules

2 x mc-110 on fw 0.7-372
2 x mc-110 on fw 0.7-376 (installed to test before updating other two)
1 c mc-120 on fw 0.8-415 (I updated this one module from a recent purchase)

Curiously you updated the site and mc-110 for the 0.8-414 beta for both mc-mods the very next morning after my 376 updates. And the 414 update for the 120 seem like a step back as I somehow installed 415. I suspect I am using unstable versions on all modules then?

I am confused though. The he current updates for the mc-110 contain the fw file "mcMod110-v0.8-374.bin", which would seem to be the version between my 2 sets of 110 modules, not a 414 upgrade. it's somewhat confusing if the files in the archives do not match the published version.

While I'm typing I went ahead and up/down graded the mc-120 to fw version 0.8-414 and one mc-110 to 0.8-374. The gateway is still unable to see them. I don't have the old OTA and USB fw to roll back the gateway as an experiment.

I have rebooted and re-installed mc-studio several times as well. As I said, everything was working fine until I updated the GW last Thursday-ish.

Thanks,
Brad


The mc-120 archive contains

mc-T2

  • Administrator
  • Full Member
  • *****
  • Posts: 239
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Re: Access old firmwares
« Reply #3 on: April 03, 2017, 04:06:39 pm »
Hey Brad,
looks like when we switched over to the new website that we had some mistakes on the version #'s available. We also had an old version of mcStudio which, I believe, is the main part of the problem you are experiencing.
The newest version is now available on the website and we have fixed all the version #s that were causing confusion.

Can you please download the new version of mcStudio (v0.8-399) and also update your gateway to the latest host processor (v 0.8-421) and let us know if this solves the problem.
Sorry for the confusion and thanks for the patience
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB

bdevlin

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Access old firmwares
« Reply #4 on: April 04, 2017, 11:27:10 pm »
OK, already on 421 host gateway but was on 363 fw, upgraded to 367 from the updated site. The new MC-Studio can now see my (in range) modules when connecting to gateway. My modules are still not relaying my data through the gateway though. I did update two modules to the latest FW as per the update. Do I need to redo the OTA code to the modules? This wouldn't make sense, as my existing old FW modules 'were' working fine, but if that's the case, let me know.

One more thing... MC-Studio constantly crashes on me. Any tips? It is extremely unstable on my Windows 7 laptop. It's corporate issued, so is virus checked and all that. I am also local admin on my computer.

Thank,
Brad

mc-T2

  • Administrator
  • Full Member
  • *****
  • Posts: 239
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Re: Access old firmwares
« Reply #5 on: April 06, 2017, 11:02:44 am »
Hey Brad,
Depending on what code you are running on the modules, you may need to reload your programming. There was some changes to the new mcStudio and the gateway that may affect the code that you are running. In general this should not be the case but let's see if this helps you out.

Can you please try re-compiling your code and then load it back onto those modules and see if the data starts to flow again?

Otherwise, has there been any changes to your network at all as this could also affect the data flow?

Quote
One more thing... MC-Studio constantly crashes on me. Any tips? It is extremely unstable on my Windows 7 laptop
Can you take some screen shots of the errors you are seeing when mcStudio crashes? Also, we have made some significant improvements to the next version of mcStudio that solves many crashes and file pathway issues. I don't have a hard release for the next version but it is coming soon!
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB

bdevlin

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Access old firmwares
« Reply #6 on: April 06, 2017, 05:40:01 pm »
I realized the file path issues are a major hiccup and cause of crashes. I eagerly anticipate the next release.

Reprogramming get's data flowing again. All the other units were on mc110 fw 372 when they were working, but changes to the gateway may explain the problem. I have pulled all the units and re-flashing the updates and working on some new generic code for the modules, rather than manage the same code for each module independently. I bulk device push feature would be cool.

It looks like we're fixed for now.
Like Like x 1 View List

mc-T2

  • Administrator
  • Full Member
  • *****
  • Posts: 239
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Re: Access old firmwares
« Reply #7 on: April 07, 2017, 09:19:33 am »
Great, sorry for the hassle!
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB