Author Topic: Re-Post "Updating the gateway, general issues"  (Read 135 times)

mcThings

  • We Connect Things To The Internet... That Can't Be Plugged In.
  • Administrator
  • Jr. Member
  • *****
  • Posts: 68
    • View Profile
    • www.mcthings.com
Re-Post "Updating the gateway, general issues"
« on: June 06, 2016, 11:03:51 am »
jeffmartin1din Support5
Updating the gateway, general issues
0
I received my Kickstarter package and downloaded all the available files from the web site today. I read through the forum to see if there were any issues with the hardware and noticed that people were having problems uploading the new firmware into the gateway because their USB sticks drew too much current. I tried three of my sticks (all USB 2.x) with a USB power meter and found that they all drew 50-80mA while in use. None of them worked with the gateway. The sticks' LEDs wouldn't even light up. I tried using the USB power meter to determine what was happening, but the same thing happened and the meter indicated 0mA. There was 4.97V available at the USB port. I think that might be due to the fact that the power meter may draw more than the gateway can provide and left nothing available for the memory stick.
I used the USB meter to determine the current draw of the gateway and found it to be 240-270mA, well within the power requirements of my laptop. I tried using a 2.1A wall wart to provide power just in case that was a problem but I still had no luck.
I fired up ve rsion 0.7.890 of mcStudio and it can't find my gateway. That might be another issue on my side. To verify the version, I selected Help-About. When that screen pops up there is no Close button. Dinking around with the mouse finally made it go away. A close button here would be helpful.
I checked the Options-Logging screen and made a few selections. Closing that screen popped up another screen saying the mcStudio had stopped working.Like

kristofferis
kristofferis1d
Hello. Let's start with the simple question, in mcStudio, to close the pop-up just click on it, not outside of the pop-up just on it.
About the USB, if I am updated on this, it is not the actual current that the device use its what the device telling the USB host that is its max current.
So even if your device current draw is 80mA maybe it is telling the host that max Icoul draw is 120mA. And that is why the USB host it discontinue the negotiation.
I don't know what version of firmware that you now have installed on the gateway so it's hard to troubleshoot the connection issue that you experienced.
My best bet is that you try with som other USB device and update the Gateway.
If you check your DHCP server, did the gateway get any IP address? And if it did, could you ping it from the computer running mcStudio?Like

jeffmartin
jeffmartin5h
Clicking on the About pop-up doesn't close it immediately. Either there is some timer that keeps it open or you have to click outside the pop-up several times to get it to close.
I found two USB sticks that require less than 100mA. They still don't work. I found two more ancient sticks that I'll try later. This is an issue if you have to dig around to find ancient USB sticks to update the firmware.
I finally got my gateway onto a network. I had to try another network (the original network is my work network and I think there was an issue with the firewall or something). The gateway firmware version is 0.6.352. I managed to get the gateway to connect to mcStudio (the IsChecked box was checked). However, at no time did the “Connected Device” part of the Device Maintenance and Connection screen indicate it was connected to anything other than the Virtual Gateway. I selected the real gateway and the one mcModule I had powered up showed up. The beacons were being received. I tried Connect Device and it never connected, though.Like

kristofferis
kristofferis4h
Well, on my computer the closing is immediately. I verified it before this post.
It seems that many people has issue with the update from USB, I used one USB 2 – 4gb memory stick that I have used for firmware update on many hardware and it also works against mcGateway.
This is a very new product and there is new firmware released very often, have you updated your mcModule with the mcDongle OTA update? So that your modules run the latest firmware?Like

jeffmartin
jeffmartin2h
I finally found a USB stick that works. I think. The firmware updated to 06-355 according to mcStudio. The LEDs definitely acted differently, so I am going to assume that it updated.
I didn't get a mcDongle in my shipment for some reason. The packing slip shows one was supposed to be received but it never made it into the package. My customer ID is 52, so you should be able to trace my shipping address.
Am I correct in guessing that I won't see a Connected Device until I get my mcModules updated? And that I can't update them until I get the mcDongle?Like

kristofferis
kristofferis2h
Good that you found a working USB stick.
Some of the mcThings admin has to answer about the shipment.
I just tried to connect to a unpatched mcModule and I did not managed to connect to it. Same for me, it sends beacons.
So yes, I think you have to update the mcModules before you could connect to it.
I don't know about any other way then OTA with mcDongle to update the firmware

Social Buttons


kristofferis

  • Sr. Member
  • ****
  • Posts: 287
  • Location: Sweden
    • View Profile
Here is the rest of the conversation from old forum:

jeffmartin4h!
I found the mcDongle. Darn thing looks like a mcModule when it is in the wrapper. I'll try to update the mcModule and see what happens.

kristofferis
Great, please let us know the result.

Like Like x 1 View List

jeffmartin

  • Newbie
  • *
  • Posts: 5
    • View Profile
I upgraded two mcModules (all I had batteries for at the time) and the gateway. The version returned on the modules after upgrading was 0.6-355 and not 0.7-356 as I expected. Did the version in the new code get changed to the proper version?

At any rate, I am now able to communicate with at least one of my modules. mcStudio only saw one of the two upgraded modules. Not sure why it didn't see the second module.

mc-T2

  • Administrator
  • Sr. Member
  • *****
  • Posts: 251
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Hey Jeff.
Can you try updating the module again (using the mc-OTA process) and ensure that you are updating it with 07.356 version for the modules. We have seen some folks accidentally update their module with the mc-Gateway firmware instead of the module firmware and if that is the case, you wouldn't be able to see that module in mc-Studio. Try that and let us know if you can see the other module
Thanks!
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB

jeffmartin

  • Newbie
  • *
  • Posts: 5
    • View Profile
I checked my versions and I found that both were flashed with the latest firmware. I must have had a brain fart.

I downloaded mcStudio 891. When you check the version using About, it shows 890.

I connected to my gateway. I can now see my modules. Woohoo!

I tried to change the Temperature program to change the red LED based on TempF. I used Save As. That doesn't work very well. Saving a project apparently creates three files. Save As only saves one. When you close studio and try to restart the program it won't run. I tried Save As and Save All before I closed studio.