mc-Things

mc-Products => mc-Module => Topic started by: helge on July 15, 2016, 03:34:51 pm

Title: [SOLVED] Power consumption of mcModule 110
Post by: helge on July 15, 2016, 03:34:51 pm
I just tried out some sketches and I'm wondering about the high power consumption of the module. The Shared Event ButtonPressed (LightSwPublish example) eats steady 1 mAh, same does the accelerometer Shared Event AccelerometerInt1(). In both configurations the modules are just sitting there and waiting, no action performed.

I really hope this is not true. Any input is welcome.

UPDATE: Uploaded screenshot and capture data. I've also verified that the Gateway, Module and Software is up-to-date. Gateway (0.6-360, 0.7-405), Module (0.7-359), Software (0.7-895)

[attachment deleted by admin to save space in attachment file]

[attachment deleted by admin to save space in attachment file]
Title: Re: Power consumption of mcModule 110
Post by: mc-John on July 17, 2016, 06:09:30 pm
That must be a firmware problem. When an event is set the port has to be reprogrammed so we can detect the interrupt. I suppose we made a mistake with reprogramming. We will look into this Monday.

The sleep current is currently between 5 and 6 uA.

-John-
Title: Re: Power consumption of mcModule 110
Post by: mc-Abe on July 18, 2016, 03:17:58 pm
There seems to be an issue with the micro controller we are using and the peripheral that handles these events. We are working on a workaround to reduce the power consumption. It is a bit involved so will need a few days to come up with a solution.
Title: Re: Power consumption of mcModule 110
Post by: helge on July 19, 2016, 08:52:54 am
Ouch! The first part of your answer hurts a lot. Jeeez. :(
Title: Re: Power consumption of mcModule 110
Post by: kristofferis on July 19, 2016, 10:44:28 am
Better to focus on the part that say they will fix it  ;)
Title: Re: Power consumption of mcModule 110
Post by: mc-Abe on July 19, 2016, 12:52:58 pm
This issue is now resolved and the fix will be in the next version that should come out today.
Title: Re: Power consumption of mcModule 110
Post by: helge on July 19, 2016, 02:26:33 pm
Wow! Thumbs up! That's really great. Was it bug #39 with the nrf51?
Title: Re: Power consumption of mcModule 110
Post by: mc-Abe on July 19, 2016, 03:30:42 pm
It sure was. A bit of surprise to us as well as we missed it in the errata. Note that this version is now available for download so you can go ahead and try it to make sure it solves your problem. I did a test with the button enabled and the current draw stayed between 5 to 6uA.
Title: Re: [SOLVED] Power consumption of mcModule 110
Post by: helge on July 20, 2016, 04:27:28 am
I can confirm that the ButtonEvent, ReedSwitchEvent and AccelerometerInt are down to expected power consumptions. Thank you for the almost instant bugfix!