mc-Things

mc-Products => mc-Module => Topic started by: rvdvoort on July 16, 2016, 04:10:00 am

Title: Module MC 110 stops publishing to MQTT broker.
Post by: rvdvoort on July 16, 2016, 04:10:00 am
I have a Module set-up which publishes the temperature to a MQTT broker (installed on my own server) every 5 minutes. Publishing stops completely every 1 or 2 days. When I remove the battery from the module and install it again it starts working again.

I also want to mention that during the day that it is working it sometimes skips one or two publishing moments (so it takes 10 to 15 minutes for the next update, instead of the 5 minutes)

I have the latest firmware installed on the module/MC gateway and only 1 module is connected to the gateway.

Any ideas what is causing this?
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: kristofferis on July 16, 2016, 04:18:40 am
Could you please post what version you have on your mcGateway, and on your module. Do you use Ethernet or wifi on your mcGateway?

I have seen what you mentioned about the module skipping update but not completely stopped.
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: rvdvoort on July 16, 2016, 05:40:28 am
Gateway is hardwired.  I believed all software was the latest version but it wasn't. The Mc Module was stil on version 358. I have now updated to version 359 but that created another problem.

In debug mode it workes fine and publishes to the broker. However as soon as I load the program into the module it doesn't publish any more.
To make sure that the program was working I added a blinking LED in the loop. That was also NOT working when I load it in the device. So I tried the simple program "blinking LED". Also this was not working when loading on to the module (all was working fine in debug mode)

I have reloaded the .359 software but still nog go (although it is working in debug mode) It seems that something is wrong with version .359.
I will do some further testing or revert back to the older SW version for the Mc Module.

Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: kristofferis on July 16, 2016, 05:49:27 am
Have you updated the mcGateway both with USB and mcDongle?
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: rvdvoort on July 16, 2016, 06:04:27 am
MC gateway was already on latest version 6-360 / 7-405.

Downgrade the Mc Module back to 7-358 and all is working again.
So I believe there is something wrong with version 7-359 for the Mc Module

See screenshots of version I have now loaded (downgraded back to version 7-358 for the Mc Module)

Not sure why the 7 - 359 version doesn't work. Any clue??

[attachment deleted by admin]
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: kristofferis on July 16, 2016, 06:34:02 am
Iam running at latest version and publishing to MQTT broker, have you tried to upload the code again to the mcModule after the firmware upgrade to 7-359?
Do you use any special function in your code or is it simple temperature reading?
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: rvdvoort on July 16, 2016, 08:36:31 am
No programs are working with the 359 version. Even the simple blinky program doesn't run (it does run in debug mode) I have tried re-uploading the 359 version twice without succes.

I will try upgrading another Module.

Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: mc-Abe on July 16, 2016, 11:45:44 pm
Can you please update your mc-studio. We sometimes make changes that make the code generate with mc-studio not backwards compatible. This was the case on this release. My apologies, I was supposed to make an announcement about that and I forgot.
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: rvdvoort on July 17, 2016, 03:43:20 am
Upgrading Mc Studio to the latest version did solve the issue with version 359.

Will now have to wait and see if the initial problem is also solved with the new SW version. (Mc Module stopping with publishing after a certain time)
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: kristofferis on July 17, 2016, 06:03:18 am
Its important to always run the latest version of all components.
Good that it solved the issue for you.
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: rvdvoort on July 17, 2016, 06:20:02 am
That we have the latest versions is clear but this wasn't that obvious this time. When I downloaded 359 the release note was saying 30th june. And if this was indeed correct I had the latest version of Mc Studio.

In another thread it was mentioned that this 30 th june was incorrect and has now be changed to 15 July. At the time of the download I wasn't aware of that fact.

Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: kristofferis on July 17, 2016, 06:32:07 am
I was just pointing out the importance in running latest version on all components.

We have seen a lote of strange issues and many of them where version related.
Title: Re: Module MC 110 stops publishing to MQTT broker.
Post by: mc-Abe on July 17, 2016, 10:42:10 am
We made a mistake while updating the release notes. Sorry about that. We appreciate your patience as we are very rapidly changing things and improving the stability of the platform. Unfortunately sometimes the changes break backward compatibility.