mc-Things

mc-Products => mc-Module => Topic started by: bailejor on April 28, 2017, 06:30:17 pm

Title: Firmware update broke connection
Post by: bailejor on April 28, 2017, 06:30:17 pm
I just updated my firmware to v.8-415 and I can no longer connect to the module via the gateway (Tried probably 50 times and waited as long as 300 seconds). I also can no longer find the gateway nor the module with the Mcdongle. Anyone have any suggestions?
Title: Re: Firmware update broke connection
Post by: mc-T2 on May 02, 2017, 12:55:29 pm
Have you updated the gateway to the latest versions as well (both the GWHost and the application processor)?
Also, are you using the latest version of mcStudio?
Title: Re: Firmware update broke connection
Post by: bailejor on May 02, 2017, 04:21:51 pm
The Gateway version is 0.6-367 and the LPLan is 0.7-403.

I was able to update the application processor with a flash drive, but I can't use Mc-OTA to update the other processor because the mcdongle will not detect the mcgateway.

Thanks for your time by the way. It is much appreciated.
Title: Re: Firmware update broke connection
Post by: mc-T2 on May 03, 2017, 09:25:04 am
Hi bailejor,
Ok, yes you are out of date on the GWHost version. Your mcDongle should recognize your gateway as it did to recognize the modules when you updated them.

Ensure you are following the process correctly as laid out in the mcOTA guide and the mcGateway guide. When you start mcOTA, ensure your dongle is plugged in and that it is recognized by the mcOTA application. From there, you need to press 'search' and then power cycle the gateway so that the mcDongle can recognize it and then you can proceed with the update. It doesn't sound like there is anything wrong with the mcDongle since you were able to update the modules previously. Please try again and let us know how it goes.