mc-Things

mc-Products => mc-Studio => Topic started by: b.badkoubeh on January 09, 2018, 10:56:40 am

Title: Unable to Configure MQTT on McStudio
Post by: b.badkoubeh on January 09, 2018, 10:56:40 am
I'm trying to configure MQTT on McStudio to connect to Microsoft IoT hub. All my attempts for saving the MQTT config on mcstudio failed. Is mcthing compatible with Azure IoT hub? What could be the issue?
Title: Re: Unable to Configure MQTT on McStudio
Post by: b.badkoubeh on January 10, 2018, 02:48:26 pm
To be more specific, once I try to configure the gateway that I have been connected to, the mcstudio disconnects from the gateway and the configuration window opens with some gray fields. It doesn't let me change and save any fields.

 
Title: Re: Unable to Configure MQTT on McStudio
Post by: mc-John on January 12, 2018, 02:37:15 pm
But it looks like you changed some variables in the gateway. You have to use port 1883 because the gateway does not support SSL

Our new cloud product does not have this problem. It let you connect seamlessly to IoT-Hub.
Title: Re: Unable to Configure MQTT on McStudio
Post by: b.badkoubeh on January 12, 2018, 03:08:49 pm
I think since I upgraded the firmware from 615 to 658, this happened.

When I open the Gateway Config window, the gateway disconnects automatically so that it doesn't allow me to change the port or any other settings. Attached is the error I always get.

Please advice.
Title: Re: Unable to Configure MQTT on McStudio
Post by: mc-John on January 15, 2018, 10:33:44 am
Can you go back to the previous version and see if that helps?
Title: Re: Unable to Configure MQTT on McStudio
Post by: b.badkoubeh on January 15, 2018, 11:10:08 am
Thanks John for the response!

Looks like I overwrote on the old file and don't have it anymore. Where can I find the older firmware versions?