Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bdevlin

Pages: 1 2 [3]
31
mc-Things General Discussion / Re: Access old firmwares
« on: April 03, 2017, 11:22:21 am »
I have the following modules

2 x mc-110 on fw 0.7-372
2 x mc-110 on fw 0.7-376 (installed to test before updating other two)
1 c mc-120 on fw 0.8-415 (I updated this one module from a recent purchase)

Curiously you updated the site and mc-110 for the 0.8-414 beta for both mc-mods the very next morning after my 376 updates. And the 414 update for the 120 seem like a step back as I somehow installed 415. I suspect I am using unstable versions on all modules then?

I am confused though. The he current updates for the mc-110 contain the fw file "mcMod110-v0.8-374.bin", which would seem to be the version between my 2 sets of 110 modules, not a 414 upgrade. it's somewhat confusing if the files in the archives do not match the published version.

While I'm typing I went ahead and up/down graded the mc-120 to fw version 0.8-414 and one mc-110 to 0.8-374. The gateway is still unable to see them. I don't have the old OTA and USB fw to roll back the gateway as an experiment.

I have rebooted and re-installed mc-studio several times as well. As I said, everything was working fine until I updated the GW last Thursday-ish.

Thanks,
Brad


The mc-120 archive contains

32
mc-Things General Discussion / Access old firmwares
« on: April 02, 2017, 11:24:41 pm »
I updated my gateway to the latest software and firmware 06-367 and 0.7-421.

The gateway no longer accepts messages from my modules scripts at all, so my entire test scenario is now broken. I am using the latest mc-Studio 0.7-906, and the gateway can connect, but will not detect devices for programming at all. I have one device sitting directly on top of the gateway. The beacons do show for all modules in range. Very frustrating. Any tips or an archive of old soft/firmwares please.

I have four active modules working reasonably well before this update.

Thanks,
Brad

33
Announcements / Re: Announcing mcStudio Version 0.9!
« on: February 24, 2017, 01:40:15 pm »
Awesome!. I can code and understand polymorphism, but what about the wizard from the kickstarter for all of the non coders?

34
mc-Studio / Frequent crashes with mc-studio
« on: January 06, 2017, 10:51:09 pm »
This app constantly crashes. 2 days ago I re-installed, rebooted... it still crashed. I manually removed everything from the windows install directory and my appdata . Then it worked, but broke my apps. I have them all in text so it was just copy/paste. Maybe implement a send error details to mc-things option so you guys can debug.

35
mc-Module / Re: Possible range between McModule - McGateway
« on: January 06, 2017, 10:43:06 pm »
Cool! I was planning on getting another 5 modules, but now I'll wait for the new gateway ! So I can use the two gateways in tandem with my 5 110 mods and future 120 mods?. I want to put the 110's in my raised bed garden and use new 120's to monitor fermentation temperatures (kombucha and real pickle).

36
mc-Module / Re: Possible range between McModule - McGateway
« on: January 05, 2017, 10:53:37 pm »
This is a great topic. I am surprised there is not more on this. My home lot is 150ft x 150ft... Wood construction. The max distance for my mc-Module 110 from gateway is maybe 40 ft to garage or back yard. I have played with various positions for the gateway to accommodate the module locations. This seems to see all of them some of the time, but I miss a lot of broadcasts. I am using IFTTT which I think is one and done, so I may start playing with MQTT and QoS levels, but there is only a door sensor example and I'm not clear on it yet. I am setting up a Raspberry PI with Mosqquitto soon so I can play with the examples and QoS with a local Postgres or MySql database.

The gateway crashed on me just as I was showing my colleagues my awesome temperature visualizations in Tableau on the data logged through IFTTT in Google sheets. I didn't know until 6 hours later as I have the visualization hooked up on my phone as well. Is there a debug log for the gateway I can send you somehow? I have no idea what happened, but I reset the router and the beacons started coming back up and logging data

This is my layout, the gateway is inside on the second floor. The garage is the furthest and behind a fire rated wood door. I could raise it up, but then the temperature is not as accurate because heat rises. Garage and Back yard are most problematic. Back yard is in a use aspirin container wedged into some branches of a 3 foot cedar, but is only 30-40 ft from the gateway, yet through an exterior wall.

Layout:




                                  South Back Yard
                                           *






                                       Gateway 110



                                                                                                               Garage
                                                                                                                  *

                                                       Kitchen
                                                          *

Master Bedroom
      *

Some data streaming from all mc-Module 110's again:
January 5, 2017 at 08:23PM   Main_Floor_Temp   20.8125         10085
January 5, 2017 at 08:26PM   Garage_Temp   -1.25         10089
January 5, 2017 at 08:26PM   Main_Floor_Temp   20.75         10085
January 5, 2017 at 08:27PM   Upper_BackYard_Temp   -3.5625         0001008a
January 5, 2017 at 08:29PM   Garage_Temp   -1.25         10089
January 5, 2017 at 08:29PM   Main_Floor_Temp   20.75         10085
January 5, 2017 at 08:30PM   Upper_BackYard_Temp   -3.5625         0001008a
January 5, 2017 at 08:31PM   Master_Bedroom_Temp   19.5625         10091
January 5, 2017 at 08:32PM   Garage_Temp   -1.25         10089
January 5, 2017 at 08:32PM   Main_Floor_Temp   20.75         10085
January 5, 2017 at 08:34PM   Master_Bedroom_Temp   19.5         10091
January 5, 2017 at 08:35PM   Garage_Temp   -1.25         10089
January 5, 2017 at 08:35PM   Main_Floor_Temp   20.6875         10085


You can have a look at my visualization, although it's not live because our free product requires a manual refresh and upload. I have a reasonably live (not streaming) version on my own server.
https://public.tableau.com/views/TemperatureIoTmc-ThingsIFTTTGoogleSheets/Temperature?:embed=y&:display_count=yes

Can we get some info on optimal antenna orientation? This is something I can control at install, but I am guessing all the way right now.

37
Thanks, I did the USB update yesterday but I guess it didn't take. I reformatted my USB stick and reflashed this morning after you pointing out the FW revision was older. Now it works! I'll try the MQTT tutorial today or later tomorrow. Sorry to waste every one's time, but I thought everything was updated correctly.

38
Any advice? You can see it's the latest firmware. Basically it's impossible to set up the MQTT details as per the video tutorial.




Pages: 1 2 [3]