Recent Posts

Pages: [1] 2 3 ... 10
mc-Plug / Re: McPlug
« Last post by davecason on May 24, 2017, 05:19:52 pm »
Ya know  ......  This getting annoying ! 

Here I have a fuggen Dell Workstation - a T7400 with two Xeon E5440's processors and 64 GB of RAM and for shits and giggles 9.3TB of space.

It'd be freaken great if the damm McStudio app didn't crash every single time I write something in the app for the McPlug.

I'm pretty sure it's NOT the computer and everything else connected to it, or in it, seems to run pretty damm happy, and has so done for a year !


Hey Kbrooking,

It could be that the device is still connected as a device within mcStudio which could negate its ability to send out SIGFOX messages.

Can you try:
-   Load your programming either wirelessly or via USB serial connection
-   Remove the USB from the mcDemo205 and close mcStudio
-   You can then plug the device back in via USB to provide power or power the device from batteries

This should allow you to get SIGFOX messages back as the device would then be in a state of running independently. Does that make sense? Let us know how that goes

mc-Demo205 / Re: Programming the mc-Demo205
« Last post by mc-T2 on May 23, 2017, 11:37:51 am »

the 'Erase Script' function in mcOTA is provided in the rare instance that someone writes a script that 'bricks' a device. This can happen if you write a script that loops/bricks due to poor programming (yes, it happens!).

While working with mcThings devices/modules, you can overwrite existing programming by loading new scripts through mcStudio (either wireless via the gateway or USB serial connection with an mcDemo205). Loading new programming automatically overwrites the existing programming on the module/device.

There is no need to use mcOTA as a means to erase existing programming unless you have written a script that requires you to do so.
Does that make sense?
I'm seeing this same odd behavior. So was there a final solution to resolve this issue?
mc-Demo205 / Programming the mc-Demo205
« Last post by kbrooking on May 21, 2017, 05:54:40 pm »
Do you need to erase the current mc-script on the mc-Demo205 with OTA like you do for the mc-modules before you load a new mc-script or can you just connect the usb cable and overwrite the current script with your new one?
mc-Studio / Re: Timestamps
« Last post by GarnetT on May 21, 2017, 09:34:14 am »
Thanks Nick,
I've just google'd you and am checking it out now.
Unfortunately, no. SIGFOX is a great network however there is no QOS and the mcDemo205 cannot receive downlink messages (too costly on battery consumption) so there is no way that the device can know if it is in coverage at all.

There are some easy example projects available in the mcDemo205 documentation where you can send messages and then see if they are received on the SIGFOX backend. Alternatively, you can check the coverage map ( to ensure that you are in a covered area.
mc-Plug / Re: McPlug
« Last post by mc-T2 on May 21, 2017, 09:03:35 am »
it's no good.
The example does work quite well, so I am not sure what the issue is other than that it doesn't do exactly as you wish. I pointed it out as an example of mcPlug code that you can take and modify for your own use

As mentioned, this is not a function that is built-in to the platform at this time. However, as mentioned, there are work-arounds so that you can design your own program. Have you tried to write your own script? Here is the help I provided in my previous reply:
there is no specific function to set an even to happen at a specific time however what you can do is have the device check the time at certain intervals and if the device finds that the time is within your specifications, then you can have the plug turn on or off something.

Have you looked at incorporating the examples your buddy sent over? You may also want to check around the forum as there are some recent questions and discussions about timestamps and their usage.
As mentioned, there are ways to do this. Part of the great thing about the mcThings platform is that there are almost endless ways you can program and modify devices which is why it is nearly impossible to have an example of everything you can do.

That said, if you read the documentation and take the time to putting something together, you can then provide an example script to others if you wish.
mc-Gateway / Re: Cannot see the gateway in mcStudio
« Last post by mc-T2 on May 21, 2017, 08:23:14 am »
Hi cclr,

let's start at the top and make sure you have everything up to date as using these modules for a temperature sensing network is actually quite easy and can provide a ton of value.

mcStudio - you need to be at the latest version: Current Release v0.8.399.0. This can be downloaded from the website:

mcOTA - you need to be at the latest version: Current Release v1.2.13. This can be downloaded from the website:

mcOS for devices/hardware:

Gateway: Your gateway needs to have the application processor updated as well as the host processor. You should be at:
Application Processor Download v0.6-367
Host Processor Download v0.8-421
From website:

Modules: When you download the newest version of mcOTA, you need to put your modules to the latest firmware:
mcModule110 mcOS v0.8-376 (
mcModule120 mcOS v0.8-415 (

Be sure you have fresh batteries in the modules when you go to update and be sure you follow the process for updating as listed in the mcOTA documentation as well as the mcGateway documentation.

Please confirm that all of this is up to date

You mentioned that you had used 3 computers, what is the OS versions for these computers?

mc-Gateway / Re: Cannot see the gateway in mcStudio
« Last post by cclr on May 21, 2017, 02:24:43 am »
I have all FW and SW up to date. I have tried 3 different PCs without luck. In the past couple of days I cannot see at all the mc110 modules in mcOTA updater anymore. I used new batteries, different modules. The mcOTA application seems to see the dongle (indicated by 'Ready' text) but the modules are not found. The gateway is not seeing anything also. I have read relevant topics in the forum but so far I cannot make this work.

It is frustrating since I have been planning to use these modules in a large project, with at least 30 modules per gateway, monitoring temperature in an industrial environment.
Is there any low level serial debugging that I could do?
Pages: [1] 2 3 ... 10