Recent Posts

Pages: 1 [2] 3 4 ... 10
11
MQTT / Re: mcGateway110 - How to change the configuration for MQTT server?
« Last post by NorGer on January 03, 2018, 10:20:53 am »
Hi mc-Abe,

Thanks for you answer.
I have tried more times to get configuration data form the mcGateway and the results are allways the same.
Additional info: my mcGateway was connected to the home network trough wifi. In this case the gateway configuration window allways appeared about after 30 sec and there were allways some non editable textfileds. I received allways an error message - the data are not saved - if I tried to edit an active filed (for example the Time Zone) and save the data to the gateway. 
The descrided situation is allways reproducable.

I have done some other tests today. I have connected the mcGateway to the network trough LAN cable. The results are the followings:
1. mcGateway can connect to the mc Studio more faster as in the case with wifi
2. gateway configuration window appears very fast after the mouse click
3. but the gateway configuration window shows the same situation as in the case with wifi (there are some fields in grey - it seems they are the same fields)
4. edit the Time Zone (it is not grey) and save the data to the mcGateway does not cause any error message, but the modified data are not saved.

I have also tried to edit the GWSettings of virtualGW, but it seems that there are the same problems, grey fields. But here are all fields grey. See attachment.

Can there be any problem with my system configuration or settings? I use Win8.1 Pro 64 Bit. The .Net 4.6.2 Framework is installed with KB3151864 package.

Do you have any idea? What kind of settings should I check?
12
MQTT / Re: mcGateway110 - How to change the configuration for MQTT server?
« Last post by mc-Abe on January 03, 2018, 09:32:22 am »
The configuration details are retrieved one at a time from the gateway and when no response is received for an item, the textbox corresponding to that item is greyed out. This was implemented to allow variability in number of configuration items as we added more in later versions. The greyed out boxes you have are rather odd though. Have you tried this a few times? It is possible that sometimes the messages do not get all the way back.
13
MQTT / mcGateway110 - How to change the configuration for MQTT server?
« Last post by NorGer on January 02, 2018, 04:48:57 pm »
Hi mcThings Team,

I would like to send MQTT messages from my mcModule120 to my private MQTT server installed on a NAS which is connected to my private network. As I know, first I have to change the configuration of the MQTT server on the mcGateway110.

actual mcGate SW status:
- GwVersion: 0.9-958
- LpLan Version: 0.9-615

I have successfully connected the mcGateway to the mcStudio and the "Gateway Config" button was active on the "Device Maintenance and Connection" window, but on the "Gateway Configuration" window the MQTT Server textbox is never editable (it is always grey). I can edit only the port, username, password textboxes. (see attached screenshot)
Is there any possibility to set a private MQTT server for the mcGateway110?
It would be nice if you could describe the exactly steps and the requirements to change the MQTT settings.

Thanks a lot!
14
mc-Innovations / Re: mcModules goes cold
« Last post by kristofferis on January 02, 2018, 08:53:24 am »
Yes, that is true, and remember that they send temperature update every minute  :)
So this is very impressive.
15
mc-Demo205 / Re: Water temperatures
« Last post by AndrewPratt on December 31, 2017, 11:18:07 am »
As a follow up update we have now had the 205 outside during this bitterly cold stretch over Christmas and it has continued to push out hourly updates without issue. Yesterday we hit -33C and it still worked fine. One thing I have seen consistently though is that with the clear front on the 205 unit it acts like a greenhouse when the sun shines directly on it so despite it been very cold I see a rise in day time temps around 1pm to well above zero for an hour or so before it plummets back to ambient temp. When I'm back in the office next week I will see about adding some sort of shade device to minimize that effect.
16
IFTTT / Re: IFTTT Webhook not working after upgrading to latest 0.9 version firmware
« Last post by bdevlin on December 21, 2017, 11:52:33 am »
Ya it's a pain, but I learned a lot re-architecting for MQTT with Python and Postgres SQL. It was worth it for sure, as it's now mostly in my own sandbox. I struggled to IFTTT working again, then finally gave up. A month later in my spare time I was able to produce a far more stable workflow. As  long as the gateway works, that is.
17
mc-Things General Discussion / Re: Gateway 110 stops responding on a regular basis
« Last post by bdevlin on December 21, 2017, 11:42:23 am »
I do not believe the problem occurs with ethernet, however, my topology required that the MC-110 be place near my back yard wall and there is no ethernet there, hence my preference that the WiFi functions correctly.

Based on my logs, I am 99% sure that there is no "wifi test then re-connect" code implemented in the gateway mc-110. I can duplicate the problem by resetting my router, the mc-110 gateway simply will not reconnect via wifi until I hit the reset button on the mc-110. This behavior occurred with the previous firmware, but not as often.

I think maybe you could look at that snippet of firmware code and do some re-connect tests. The simplest thing would be to put it in an intermittent reset state loop if connection is lost, until it can re-establish one. However, that would just fix my problem and perhaps cause problem for others with different use cases.
18
mc-Innovations / Re: mcModules goes cold
« Last post by mc-T2 on December 20, 2017, 10:04:46 am »
Awesome! Thanks for the update kristofferis! It looks like they barely used any voltage over the past 1+ year!
19
mc-Innovations / Re: mcModules goes cold
« Last post by kristofferis on December 19, 2017, 11:43:48 am »
I think it is time to make a new post so that all could see how fantastic the battery is and also the mcModules that just keeps going :)

[ Guests cannot view attachments ]
20
When you set a breakpoint at the line "Terminal.UartReceive()" does it get there?
Pages: 1 [2] 3 4 ... 10