Author Topic: [SOLVED]After wrong firmware update of the McModule on the gateway I can't connect & firmware on McM  (Read 232 times)


  • Newbie
  • *
  • Posts: 26
  • Belgian guy married Phillipina
  • Location: Philippines
    • View Profile
My gateway worked at first but then I started to do all kind of updates: ( it has been while ago I did this )
First I update all my McModules to VM Version:1v08r376  :)
Than I updated my firmware of my gateway hostprocessor to v. 0.8-24 via the USB stick.   :)
I tested again, but could connect to my gateway again but not to any of my McModules  :(
So I thought ok, I must also update the McModule on my Gateway, but I did it the same way as my other mcModules instead of using the mcGw110.bin
So I erased the data-store and updated with the normal McMod110xxxx.bin   :-\
After that I couldn't find my gateway anymore in mcStudio although all the Led's shows normal and I can see my gateway is connected via Newt-Pro.
Than I realized I used the wrong firmware and tried to flash the McDongle on the correct firmware: mcGw110.bin but no luck:
I got the message : Total firmware size exceeds free upload space available in the device. Unable to proceed the update  ???
Help I'm stuck !!! ::)

OK, solved it:

I just chose the wrong file in mcOTAupdater  :P
Mixed up mcGw110.bin and mcGwHost110.bin

I thought maybe to remain this message instead of deleting it. So you can read my stupidities and maybe also solve yours ;)

« Last Edit: April 07, 2017, 02:12:51 am by rudydevolder »

Share on Facebook Share on Twitter

Like Like x 1 View List


  • Administrator
  • Sr. Member
  • *****
  • Posts: 252
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Thanks for sharing Rudy, glad you have it working now!
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: