Author Topic: mc-Studio crashes on startup  (Read 407 times)

kbrooking

  • Full Member
  • ***
  • Posts: 104
    • View Profile
mc-Studio crashes on startup
« on: September 06, 2016, 10:05:23 am »
I just installed mc-Studio on a Windows 10 machine and get the following error on startup.

"ERROR in mcStudio supporting thread. System.NullReferenceException: Object reference not set to an instance of an object....
see attached for further details of the error.

So far I have only downloaded and installed mc-Studio. I have not yet connected to any devices. Only tried to start mc-Studio and is as far as I've got.

Any suggestions would be greatly appreciated.




[ Guests cannot view attachments ]

Social Buttons


mc-John

  • Global Moderator
  • Full Member
  • *****
  • Posts: 212
    • View Profile
Re: mc-Studio crashes on startup
« Reply #1 on: September 07, 2016, 09:07:51 am »
I found the problem. Will publish a update today.

mc-John

  • Global Moderator
  • Full Member
  • *****
  • Posts: 212
    • View Profile
Re: mc-Studio crashes on startup
« Reply #2 on: September 07, 2016, 12:54:14 pm »
New version (Build 899) should solve the issue. It can be downloaded from our web-site.
Like Like x 1 View List

kbrooking

  • Full Member
  • ***
  • Posts: 104
    • View Profile
Re: mc-Studio crashes on startup
« Reply #3 on: September 07, 2016, 01:56:38 pm »
Yep, working now. Much appreciated.

carlinyos18

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: mc-Studio crashes on startup
« Reply #4 on: February 20, 2017, 05:07:15 am »
I have the same problem on windows 10, working with a minix computer (intel atom z35xx). mcStudio crashes with the same error.

I downloaded the last mcStudio available.

mc-T2

  • Administrator
  • Full Member
  • *****
  • Posts: 246
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Re: mc-Studio crashes on startup
« Reply #5 on: February 21, 2017, 05:32:13 pm »
Hey Carlinyos18,
Can you post a picture of that error to this thread please so we can take a look?

And just to confirm, you are using V0.8-373 of mcStudio from the website?

Thanks!
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB

McHome

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: mc-Studio crashes on startup
« Reply #6 on: February 21, 2017, 09:45:16 pm »
I have the same problem. McStudio was working and I was able to program but now something causes it to crash on startup and I have unistalled and reinstalled and it does not fix it. Any ideas? See attached file for details.


mc-John

  • Global Moderator
  • Full Member
  • *****
  • Posts: 212
    • View Profile
Re: mc-Studio crashes on startup
« Reply #7 on: February 22, 2017, 02:48:49 pm »
This error occurs when you have a no files in the project. It is solved in the latest version but I realized that this version is not yet distributed.

You have to delete your settings file in the document directory C:\Users\your name\Documents\mcThings\mcStudio


mc-Eric

  • Global Moderator
  • Newbie
  • *****
  • Posts: 6
    • View Profile
Re: mc-Studio crashes on startup
« Reply #8 on: February 22, 2017, 03:16:54 pm »
I have the same problem. McStudio was working and I was able to program but now something causes it to crash on startup and I have unistalled and reinstalled and it does not fix it. Any ideas? See attached file for details.

With no files in the project, I wasn't able to reproduce this issue on the latest version of mcStudio (v0.8.399.0). I've attached it to this message and it's available at https://www.mcthings.com/downloads/. Can you confirm that you have the same version installed?

If the problem persists after performing the steps John suggested, send us your Settings.xml file and the .mcProj file that you were working on before the issue started and we'll confirm that they're not corrupted or anything.
« Last Edit: February 22, 2017, 03:20:13 pm by mc-Eric »