Author Topic: Re-Post " starting from ground zero "  (Read 103 times)

mcThings

  • We Connect Things To The Internet... That Can't Be Plugged In.
  • Administrator
  • Jr. Member
  • *****
  • Posts: 68
    • View Profile
    • www.mcthings.com
Re-Post " starting from ground zero "
« on: June 01, 2016, 04:43:15 pm »
I update one mcModule with the firmware image …352.bin
I removed previous version of mcStudio and reinstalled the latest version 0.6.882
Got my mcGateway installed red LED solid, amber LED solid and green LED flashing.
Started mcStudio with example project Blinky.
I selected Tools/Device where I can see my mcGateway (with the right serial number) and was able to connect the gateway. Got the ‘check’ as being Active.
Had to remove and reinstalle the battery of the mcModule in order to see the device.
I selected it, but mcStudio failed to connect.
I don't if this is a result, but the green LED of the mcGateway stopped flashing.
I unplug and replug my mcGateway and started over again.
This time, mcStudio saw the mcGateway and the Device and trying connecting. I gave up after 180 seconds (3 minutes).
Gateway GWVersion is 0.6-353 and LpLan Version is 0.6-350, for your information.
Any suggestion to get me to connect to my unit. I have many more to go.Like
mnugter


mnugter16d
I had a lot of trouble getting these things to work consistently at first. When I exited the program and restarted mcStudio each time I started a new project or worked with a new module, things worked 100% of the time, provided I had entered the code correctly. I also got a lot of “fail to connects” before doing that. I got 1 and 2 lights blinking on all the modules and even loaded the programs onto a couple of them as it’s shown in Josh’s mcStudio Introduction video.
I did notice a few things (that techies most likely know but must be learned by novices like me):
- Double or single line spacing when writing code does not matter. Cut and paste wherever you can.
—This works  when you enter “Shared Event blinkLed()”, “Shared Event blinkLedRed” or ‘Shared Event LedRed“ in all cases where only one LED is used. When 2 events are entered, the colour of each must be specified, so ”Shared Event blinkLed" won’t work with 2 lights (see code on page 12 in the mcScript us er guide).
- These devices are built like a brick shithouse. I accidentally dropped one, stepped on it and it is working fine.Like


REPLY mcJohnAdmin15d
We have some people with multiple IP addresses. To check if you have that situation look your ip address for the virtual gateway is very different as your physical gateway. In the picture only the last number are changed. See attachment. CaptureLike

mnugter
mnugter15da1
My virtual gateway, virtual test gateway and USB gateway all have the same ip address 192.168.0.183Like
15d
Oops. my mcGate 110 was not plugged in Its address is 192.168.0.137Like



mcJohnAdmin15d
Great. I thought it could be that there we different addresses but everything is 192.168.0.xxx which is the standard. But plugging in definitely helps

Social Buttons