Author Topic: Re-Post "OTA bricked my McModule"  (Read 71 times)

mcThings

  • We Connect Things To The Internet... That Can't Be Plugged In.
  • Administrator
  • Jr. Member
  • *****
  • Posts: 68
    • View Profile
    • www.mcthings.com
Re-Post "OTA bricked my McModule"
« on: June 01, 2016, 05:44:59 pm »
Received the package today and tried to connect a McModule to the McGate as explained in the video. Failed to connect.
So as read on the forum, I performed an OTA firmware upgrade to v0.6-354. This went well for the first 100%, then the McModule rebooted and ended in an endless blinking RED led. McDongle indicated that firmware upgrade failed ( Now the module can be detected with the McDongle, but is unvisible for the McGate.
What to do? Any ideas?Like

mc-T2
mc-T2Admin7d
Couple questions:
- did you attempt to program the module before updating the firmware using mc-OTA?
- Can you re-attempt to update the firmware on the device again using mc-OTA please? It's possible there was an error during the initial update. please re-try and let us know what the status is afterwards. Remember to take the battery out of the module, connect the mc-Dongle and open mc-OTA. Select the firmware version and enter the module # in the top right of the screen. When you press ‘Search Device’, then insert the battery into the module to update the firmware.Like

DeGroninger
DeGroninger6da1
Couple answers:
- yes, I did try using the module before updating the firmware assuming that an older function could function as well;
- I re-attempted the procedure of updating the firmware a couple of times using your procedure, and guess what, that worked! Not the first time, but a little while later the OTA reported: success!
Thanks for the good response, the module is not bricked!Like


mc-T2
mc-T2Admin6d
Good to hear!!Like

Social Buttons