Author Topic: mcGateway110 - How to change the configuration for MQTT server?  (Read 421 times)


  • Newbie
  • *
  • Posts: 4
    • View Profile
mcGateway110 - How to change the configuration for MQTT server?
« on: January 02, 2018, 04:48:57 pm »
Hi mcThings Team,

I would like to send MQTT messages from my mcModule120 to my private MQTT server installed on a NAS which is connected to my private network. As I know, first I have to change the configuration of the MQTT server on the mcGateway110.

actual mcGate SW status:
- GwVersion: 0.9-958
- LpLan Version: 0.9-615

I have successfully connected the mcGateway to the mcStudio and the "Gateway Config" button was active on the "Device Maintenance and Connection" window, but on the "Gateway Configuration" window the MQTT Server textbox is never editable (it is always grey). I can edit only the port, username, password textboxes. (see attached screenshot)
Is there any possibility to set a private MQTT server for the mcGateway110?
It would be nice if you could describe the exactly steps and the requirements to change the MQTT settings.

Thanks a lot!

Share on Facebook Share on Twitter


  • Full Member
  • ***
  • Posts: 167
    • View Profile
    • mc-Things
The configuration details are retrieved one at a time from the gateway and when no response is received for an item, the textbox corresponding to that item is greyed out. This was implemented to allow variability in number of configuration items as we added more in later versions. The greyed out boxes you have are rather odd though. Have you tried this a few times? It is possible that sometimes the messages do not get all the way back.


  • Newbie
  • *
  • Posts: 4
    • View Profile
Hi mc-Abe,

Thanks for you answer.
I have tried more times to get configuration data form the mcGateway and the results are allways the same.
Additional info: my mcGateway was connected to the home network trough wifi. In this case the gateway configuration window allways appeared about after 30 sec and there were allways some non editable textfileds. I received allways an error message - the data are not saved - if I tried to edit an active filed (for example the Time Zone) and save the data to the gateway. 
The descrided situation is allways reproducable.

I have done some other tests today. I have connected the mcGateway to the network trough LAN cable. The results are the followings:
1. mcGateway can connect to the mc Studio more faster as in the case with wifi
2. gateway configuration window appears very fast after the mouse click
3. but the gateway configuration window shows the same situation as in the case with wifi (there are some fields in grey - it seems they are the same fields)
4. edit the Time Zone (it is not grey) and save the data to the mcGateway does not cause any error message, but the modified data are not saved.

I have also tried to edit the GWSettings of virtualGW, but it seems that there are the same problems, grey fields. But here are all fields grey. See attachment.

Can there be any problem with my system configuration or settings? I use Win8.1 Pro 64 Bit. The .Net 4.6.2 Framework is installed with KB3151864 package.

Do you have any idea? What kind of settings should I check?