Author Topic: Disconnecting your mc-Modules properly  (Read 114 times)

mc-T2

  • Administrator
  • Sr. Member
  • *****
  • Posts: 252
  • mc-Things! The opportunities are endless!
  • Location: Canada
    • View Profile
Disconnecting your mc-Modules properly
« on: June 27, 2016, 03:23:29 pm »
Hi all!
Disconnecting the modules properly may help some of you who are having inconsistent connections and re-connections to your modules. We are looking at ways to modify this to make it easier for everyone. For those of you who have issues connecting or re-connecting to modules, the following may help:

The mc-Modules will send out a connection interval every 60 seconds. However, if the module is disconnected improperly, the module may not respond for 3-11 minutes (Depending on the scenario) as it still believes that it is connected to a gateway.
To properly disconnect your mc-Module either:
1) Load the program that you are working on into the module and mc-Studio will disconnect from the module properly
2) Connect to a virtual gateway and virtual module and the connection to the physical should be disconnected properly

Another trick is to power cycle the module just before connecting to it in mc-Studio. The module will send out a connection interval within 10 seconds of being power cycled. This helps if you want to connect to an mc-Module quickly and don't want to wait for potentially 1 minute for the module to send out a connection interval
Need more mc-Modules, mc-Gateways or other mc-Things? Check out our product page: www.mcthings.com/products. mc-Development kits are available too!
Check out a live Dashboard using mcThings and Losant! Click here: https://goo.gl/ST43hB

Share on Facebook Share on Twitter

Like Like x 1 Informative Informative x 1 View List

kristofferis

  • Sr. Member
  • ****
  • Posts: 287
  • Location: Sweden
    • View Profile
Re: Disconnecting your mc-Modules properly
« Reply #1 on: June 27, 2016, 03:39:09 pm »
This is good information.
It seems that many did not know how to handle this.

Great.

gaston

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Disconnecting your mc-Modules properly
« Reply #2 on: June 27, 2016, 06:19:12 pm »
Thank you very much for this information. This is hepfull.

I got stuck in McStudio trying to connect one of my device for more than 15 minutes.
I Aborted the connection, Disconnect theGateway, close the McStudio and I removed the battery from my devices.  Then I reset the Gateway (using the reset button).
I started McStudio and open up Device Maintenance and Connection screen and connected to my Gateway.
Immediately I was able to see my Gateway no devices were visible. I put back the battery in one of my device and very quickly I sould see the device. I started the connection to this device. After 750 seconds, McStudio have not been able to establish the connection. During this time, the last beacon timestamp have been updated frequently.

Which step did I mis. What else should I do? I am using the latest version for all the environment.