Author Topic: Unable to update McModule Firmware  (Read 68 times)

tonyw

  • Newbie
  • *
  • Posts: 4
    • View Profile
Unable to update McModule Firmware
« on: July 16, 2016, 09:41:25 am »
Trying to update the firmware on the McModules to v0.7-359 without success. I had no problem when I did this a couple of weeks back.

OTAupdater is working fine, I have updated the McGateway host processor to  V0.7-405 over the air without a problem just now. But when I try to update mcModule firmware its failing. Screenshots attached.
It sees the modules fine, module is reporting current firmware version as NA which I think is strange (or maybe thats the result of it failing)

Tried uploading from different directories on my win10 incase there was some file permission issue for the mcMod110.bin file, also tried both mcMod110_v0.7-357.bin and mcMod110_v0.7-359.bin

Ive tried 3 MCModules but wont try anymore incase I am bricking them somehow :-(

Thanks, Tony
McGateway 0.6-360, 0.7-405
McStudio 0.7-895
OTAUpdater 1.2.1



[ Guests cannot view attachments ]

Share on Facebook Share on Twitter


tonyw

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Unable to update McModule Firmware
« Reply #1 on: July 16, 2016, 11:06:18 am »
As per usual I think I worked it out by trial and error....

I replaced the battery on the McModule with a brand new one and now I can update the firmware on all 3 McModules  ;D. Voltage of old battery was 3.05-2.99v , voltage of brand new battery was 3.3v.

So I suppose programming the FW needs more power from the battery ? Hopefully this thread will help others in the future.

mc-Abe

  • Full Member
  • ***
  • Posts: 167
    • View Profile
    • mc-Things
Re: Unable to update McModule Firmware
« Reply #2 on: July 16, 2016, 11:52:26 pm »
Glad you solved your problem! The update process involves erasing and writing to the onboard flash, both of which are power hungry processes. This would explain your experience.